WordPress Ultimate Member Plugin hittade sårbarhet

november 10, 2020
WordPress 5.6 kan Bryta Webbplatser i December 2020
WordPress 5.6 kan Bryta Webbplatser i December 2020
november 9, 2020
Yahoo Groups stängs helt av den 15 december 2020
Yahoo Groups Stängs Helt av Den 15-2020 December
november 11, 2020
WordPress Ultimate Member Plugin hittade sårbarhet

WordPress Ultimate Member Plugin hittade sårbarhet

Idag tillkännagavs att “kritiska och extrema sårbarheter” påverkar ett WordPress-community-plugin som heter Ultimate Member fixades. Denna sårbarhet är lätt att utnyttja och ger angriparen administratörsnivååtkomst, vilket innebär att de kan göra vad de vill till webbplatsen.

Så här skildrar Wordfence verkligheten i denna exploatering:

”Denna sårbarhet anses vara mycket kritisk, eftersom det gör det möjligt för ursprungligen obehöriga användare att enkelt eskalera sina behörigheter till en administratörs. När en angripare har administrativ åtkomst till en WordPress-webbplats har de effektivt tagit över hela webbplatsen och kan utföra alla åtgärder, från att ta webbplatsen offline till att ytterligare infektera webbplatsen med skadlig kod. ”

Ultimate Member WordPress-plugin

Ultimate Member WordPress-plugin är en typ av community-byggplugin som gör det möjligt för en WordPress-utgivare att låta läsare bli medlemmar som kan få olika åtkomstnivåer samt interagera med varandra socialt.

Det är ett svar som också kan användas för att begränsa åtkomst till innehållet till endast registrerade användare och för att tillåta olika nivåer av medlemsbehörigheter, som att publicera på webbplatsen.

Ultimat medlemssårbarhet

Det finns tre exploaterbara vektorer i plugin-programmet och alla tre är privilegierade eskalering. En utnyttjande av privilegier är när en angripare kan öka sin användarbehörighet.

Om någon till exempel är registrerad på en webbplats som prenumerant kan de göra saker som att läsa artiklar och kommentera dem.

Men med ett utnyttjande kan de höja sina webbplatsbehörigheter från prenumeranter till administratörsnivå och därmed ge sig själva kapacitet att göra vad de vill med webbplatsen.

En autentiserad exploatering av privilegier är när någon behöver ha någon form av bekräftelse, som en prenumerantroll.

Med ett obehörigt missbruk av privilegiereskalering behöver en individ inte vara en registrerad användare.

Utnyttjandet påverkar plugin-programmet Ultimate Member inkluderade två obehöriga exploateringar och en autentiserad exploatering.

Authenticated Privilege Escalation abuse gör det möjligt för en registrerad användare att uppdatera sina privilegier.

Den obehöriga utnyttjandet av privilegiereskalering gör det möjligt för en angripare att använda registreringsformuläret som en attackvektor.

Dessa bedrifter är allvarliga, kritiska och svåra.

Så här beskriver WordFence det:

”… denna sårbarhet anses vara kritisk eftersom den tillåter ursprungligen obehöriga användare att öka sina privilegier med vissa villkor. När en angripare har ökat åtkomsten till en WordPress-webbplats kan de eventuellt ta över hela och ytterligare infektera webbplatsen med skadlig kod. ”

Uppdatera omedelbart

Det rekommenderas att användare uppdaterar omedelbart till Ultimate Member WordPress-pluginversion 2.1.12. Den versionen innehåller korrigeringsfilen som åtgärdar sårbarheten.

Vi på CodeLedge är Sveriges bästa leverantörer av WordPress-utvecklingstjänster. Vi är experterna på att skapa fantastiska webbplatser för ditt företag. Prata gärna med oss ​​på hi@codeledge.com eller få en offert härifrån.

 

Lämna ett svar

E-postadressen publiceras inte. Obligatoriska fält är märkta *