WordPress Plugin WP Super Cache-Sårbarhet Påverkar över 2 Miljoner Webbplatser

mars 17, 2021
WordPress Gutenberg 10.1 Förbättrar Dramatiskt Kärnans Prestanda På Webben
WordPress Gutenberg 10.1 Förbättrar Dramatiskt Kärnans Prestanda På Webben
mars 8, 2021
WordPress Plugin WP Super Cache-Sårbarhet Påverkar över 2 Miljoner Webbplatser

WordPress Plugin WP Super Cache-Sårbarhet Påverkar över 2 Miljoner Webbplatser

En sårbarhet hittades i WP Super Cache av Automattic. Det är en sårbarhet med låg svårighetsgrad som kan göra det möjligt för en hackare att ladda upp och köra skadlig kod, vanligtvis med målet att få kontroll över webbplatsen.

Säkerhetsproblem med fjärrkörning av kod (RCE)

En brist avslöjades idag som utsätter användare av WP Super Cache för en autentiserad sårbarhet för fjärrkodkörning (RCE).

Remote Code Execution är ett utnyttjande som gör det möjligt för en angripare att dra nytta av en brist som kan tillåta dem att ladda upp och köra skadlig kod.

Den typiska avsikten är att ladda upp och köra PHP-kod som sedan tillåter dem att göra saker som att installera sekundär, komma åt och göra ändringar i databasen och uppnå administratörsnivåkontroll av webbplatsen.

När en angripare har administratörsnivåkontroll påverkas webbplatsen mycket av dem.

Som framgår av ordlistan som publiceras på Wordfence.com är detta innebörden av en fjärrkodkörning

”Remote Code Execution (RCE) sker när en angripare kan ladda upp kod till din webbplats och utföra den.

Ett fel i ett PHP-program kan acceptera användarinmatning och utvärdera det som PHP-kod. Detta kan till exempel tillåta en angripare att berätta för webbplatsen att skapa en ny fil som innehåller kod som ger angriparen full åtkomst till din webbplats.

När en angripare skickar kod till din webbapplikation och den körs, vilket ger angriparen åtkomst, har de utnyttjat en RCE-sårbarhet. Detta är en mycket allvarlig sårbarhet eftersom det vanligtvis är lätt att utnyttja och ger full åtkomst till en angripare omedelbart efter att ha utnyttjats. ”

Validerat säkerhetsproblem med fjärrkörning av kod

WP Super Cache innehåller en mängd olika RCE-missbruk som kallas Authenticated Remote Code Execution.

En verifierad sårbarhet för fjärrkodkörning är ett angrepp där angriparen initialt ska registreras på webbplatsen.

Vilken registreringsnivå som krävs beror på den specifika sårbarheten och kan variera.

Ibland borde det vara en registrerad användare med redigeringsfördelar. I det skarpaste scenariot är alla angripares behov den lägsta registreringsnivån, till exempel en abonnentnivå.

Inga detaljer har publicerats angående vilken typ av validering som krävs för exploateringen.

Detta är den extra detalj som upptäcktes:

“Autentiserad sårbarhet för fjärrkörning (RCE) (inställningssida) upptäcktes …”

Fix har utfärdats uppdatering omedelbart

Automattic, designern av WP Super Cache har uppdaterat produkten. Förläggare som använder plugin-programmet uppmanas att överväga att gå upp till den senaste versionen, 1.7.2.

Varje produktutgivare publicerar en ändringslogg som nämner för kunderna vad som finns i en uppdatering så att de vet varför produkten uppdateras.

Enligt ändringsloggen för WP Super Cache version 1.7.2:

“Fast autentiserad RCE på inställningssidan.”

Enligt Oliver Sild, VD och grundare av webbplatsens säkerhetsorganisation Patchstack (@patchstackapp):

“Det fixade problemet har låg svårighetsgrad … Men det rekommenderas ändå att uppdatera plugin ASAP.”

Vi på CodeLedge erbjuder Sveriges bästa WordPress-utvecklingstjänster. Våra WordPress-utvecklingsexperter är mycket professionella för att utveckla kreativa WordPress-webbplatser för alla typer av företag. Mejla oss på hi@codeledge.com eller få en offert härifrån.

Referenser

Patchstack-rapport: WordPress WP Super Cache Plugin <= 1.7.1 – Autentiserad sårbarhet för fjärrkörning (RCE)

WP Super Cache Changelog

Lämna ett svar

Din e-postadress kommer inte publiceras. Obligatoriska fält är märkta *

Translate »