WordPress 5.5.3 Löser alla Problem som Introducerades I den Tidigare Versionen

november 2, 2020
Användbara tips för att förbereda din webbplats för semestern i Sverige
Användbara tips för att förbereda din webbplats för semestern i Sverige
oktober 29, 2020
Google Delar Bästa praxis för Black Friday-Försäljningssidor
Google Delar Bästa praxis för Black Friday-Försäljningssidor
november 3, 2020
WordPress 5.5.3 löser alla problem som introducerades i den tidigare versionen

WordPress 5.5.3 löser alla problem som introducerades i den tidigare versionen

WordPress-utvecklingsgruppen, i en kedja av misstag, drev ut en ofullständig uppdatering som gjorde det svårt att installera nya WordPress-webbplatser. De stoppade lanseringen av uppdateringen och försökte fixa den uppdateringen men det gjorde mycket fler problem, vilket krävde en nöduppdatering för att åtgärda alla problem.

Defekt WordPress 5.5.2 säkerhetsuppdatering

Katastrofen började den 29 oktober 2020 med en standarduppdatering avsedd att ta itu med grundläggande säkerhetsfrågor. WordPress 5.5.2 var avsett att undvika problem som Cross Site Request Forgeries, XSS (Cross Site Scripting) attacker och mer.

Upprörande presenterade uppdateringen också ett fel som orsakade att nya WordPress-installationer misslyckades. Så här klargjorde WordPress felet:

“WordPress 5.5.2 … gör det omöjligt att installera WordPress på en helt ny webbplats som inte har en databasanslutning konfigurerad. Denna version påverkar inte webbplatser där en databasanslutning redan är konfigurerad, till exempel via ett klickinstallatörer eller en befintlig wp-config.php-fil. ”

För att lösa problemet, stoppade WordPress version 5.5.2 från att visa sig till fler webbplatser.

WordPress Alpha-uppdatering av misstag

WordPress satte bromsarna på ytterligare uppdateringar. Men medan WordPress-utvecklargruppen höll på att förbereda WordPress 5.5.3 redo att fixa det tidigare felet, började WordPress-autouppdateringar driva en uppdatering en gång till.

Men eftersom version 5.5.2 inte var tillgänglig valde det automatiska WordPress-systemet en alfa-version av WordPress som skulle laddas ner och installeras. Denna Alpha-version var inte avsedd att skjutas ut genom automatiska uppdateringar.

Vad gick fel

Problemen presenterades av utvecklingsteamet eftersom det inte fanns någon konventionell dokumentation om det bästa sättet att stoppa en WordPress-uppdatering. Således stoppade WordPress-teamet uppdateringen på ett sätt som öppnade dörren för Alpha-versionen att börja visa sig.

Det här problemet har åtgärdats så att situationen inte uppstår igen.

Enligt den officiella tekniska informationen:

“… det kommer inte att göras igen. Nu verkar det som ett bra tillfälle att dokumentera ett korrekt och korrekt sätt att “stoppa” en pågående utgåva, som ärligt talat inte hade försökt tidigare. Att stoppa en release är faktiskt ganska enkelt om de hade gjort rätt ändring, så medan deras försök var ett rimligt antagande att göra, visade det sig vara fel.

Släppsystemet är komplicerat och att försöka göra saker med det som inte har förväntats och dokumenterats ledde till oväntade resultat. Detta kommer att förbättras genom dokumentation och bättre kod och hantering av själva släppsystemet. ”

WordPress 5.5.3 Alpha Bugs

Problemet med WordPress Alpha-installationen var att det presenterade extra WordPress-teman och installerade Akismet.

Det är uppenbarligen inget fel med dessa teman. Utgivare som beslutar att inte ta bort dem kommer emellertid att bry sig om att hålla dem uppdaterade. Underlåtenhet att uppdatera dessa teman kan senare utgöra en säkerhetsrisk.

Enligt WordPress-meddelandet:

”Tidigare idag uppdaterade auto-uppdateringssystemet för WordPress vissa webbplatser från version 5.5.2 till version 5.5.3-alpha. Detta berodde på ett fel orsakat av förberedelser för 5.5.3-utgåvan.

5.5.3-alfa-versionen vid denna tidpunkt var funktionellt identisk med 5.5.2 eftersom inget utvecklingsarbete hade startats den 5.5.3, men följande ändringar kan ha gjorts:

Standardteman “Tjugo” är installerade som en del av pre-release-paketet. “Akismet” plugin installerat som en del av pre-release-paketet. “

En webbplats, tydligt för Alpha-utgåvan, publicerades den 29 oktober 2020, uppenbarligen felaktigt benämnd som version 5.4.3. Jag säger felaktigt eftersom WordPress 5.4 levererades i mars 2020 och det lovar inte bra att gå i omvänd ordning från WordPress 5.5 till en 5.4-version.

WordPress 5.5.3

Den senaste uppdateringen, version 5.5.3 är allt som version 5.5.2 var tänkt att vara, utan de relaterade problemen. WordPress 5.5.3 löser alla problem som presenteras i 5.5.2-versionen.

WordPress klargjorde:

”Denna underhållsversion släpper ett problem som introducerades i WordPress 5.5.2 vilket gör det omöjligt att installera WordPress på en helt ny webbplats som inte har en databasanslutning konfigurerad. Denna version påverkar inte webbplatser där en databasanslutning redan är konfigurerad, till exempel via ett klickinstallatörer eller en befintlig wp-config.php-fil.

Om du inte har 5.5.2 eller har automatiska uppdateringar för mindre utgåvor avaktiverade, uppdatera manuellt till 5.5.3-versionen genom att ladda ner WordPress 5.5.3 eller besöka Dashboard → Uppdateringar och klicka på “Uppdatera nu.”

Kontrollera din WordPress-installation

Förläggare uppmanas att se till att de uppdateras till version 5.5.3. Versioner före 5.5.2 innehåller säkerhetsproblem, så det är absolut nödvändigt att uppdateras till den senaste versionen.

WordPress 5.5.3-underhållsutgåvan innehåller ingen ursäkt för problemen, bara “tack och rekvisita” till utvecklingsteamet för att åtgärda problemen som de introducerade.

Vi på CodeLedge är Sveriges bästa WordPress-utvecklare. Vi är experterna på att göra en webbplats snabb och enkel att ladda. Prata gärna med oss på hi@codeledge.com eller få en offert härifrån.

 

Lämna ett svar

E-postadressen publiceras inte. Obligatoriska fält är märkta *