Populärt WordPress Plugin Enkelt WP SMTP Sårbarhet

december 9, 2020
Instagram-Funktioner Som du Förmodligen Inte Visste Fanns
Instagram-Funktioner Som du Förmodligen Inte Visste Fanns
december 8, 2020
5 Bästa SEO-Metoder för att Skapa Och Optimera Dina XML-Webbplatskartor
5 Bästa SEO-Metoder för att Skapa Och Optimera Dina XML-Webbplatskartor
december 10, 2020
Populärt WordPress Plugin Enkelt WP SMTP Sårbarhet

Populärt WordPress Plugin Enkelt WP SMTP Sårbarhet

Populärt WordPress-plugin Enkelt WP SMTP-plugin, med mer än 500 000 aktiva installationer, fixade bara en sårbarhet som gör att en angripare kan ta kontroll över en webbplats. Defekten i WordPress-plugin-programmet gör det möjligt för hackare att återställa administratörslösenordet och ta fullständig kontroll över en webbplats.

Enkel WP SMTP-sårbarhet

Sårbarheten finns i ett felsökningsdokument som exponeras på grund av ett mycket grundläggande fel i hur insticksprogrammet underhöll en mapp. Pluginmappar i en mapp som innehåller poster som inte är avsedda att visas av användare innehåller vanligtvis en tom index.html-fil. Syftet med den filen är att hindra någon från att navigera till den mappen och upptäcka en lista med filer i den mappen.

Om någon kan se listan över filer kan de eventuellt få åtkomst till dessa filer, vilket är fallet.

Mappen där felsökningsfilen finns saknar index.html-fil. Så på servrar där katalogindexlistor inte är inaktiverade som standard kan en skadlig hackare få tillgång till den filen.

Vad de initialt gör är att skaffa ett användarnamn på administratörsnivå från WordPress-webbplatsen som de försöker hacka med allmänt kända tekniker.

Sedan kommer de in på WordPress-inloggningssidan och skickar en lösenordsåterställning för administratörskontot.

Slutligen får de åtkomst till felsökningsfilen och återställer ett register över länken för återställning av lösenord som WordPress-webbplatsen skickade. När de återställer den länken kan de ange det, återställa lösenordet och sedan ha full åtkomst till WordPress-webbplatsen.

Mappproblem dokumenterat i Changelog

Plugin Easy WP SMTP-sårbarhet bibehåller det som kallas en ändringslogg som dokumenterar alla ändringar i varje uppdatering. Ändringsloggen är avsedd att läsas så att en användare kan förstå vad en uppdatering förändras.

När sårbarheten fixas brukar plugin-utvecklarna notera att sårbarheten fixas. Detta ger WordPress-utgivaren de uppgifter de behöver för att bestämma sig över ett utbildat beslut om huruvida de ska uppdatera ett plugin eller vänta.

En förändringslogg som informerar en utgivare om att en uppdatering stoppar sårbarheten gör att utgivaren kan bestämma sig för ett utbildat beslut att uppdatera plugin-programmet för att undvika att bli hackad.

Easy WP SMTP-plugin-ändringsloggen säger bara att de bäddar in en index.html-fil i en mapp för att hindra någon från att bläddra i den. Det borde vara en varning för att detta är en betydande uppdatering, men bara om utgivaren förstår att det är farligt att titta in i mappen.

Uppdatera plugin omedelbart

Fullständig information och beskrivning av denna sårbarhet finns på NinTechNet-bloggen.

Det rekommenderas starkt att alla användare av Easy WP SMTP-plugin uppdaterar till en version som är högre än version 1.4.2.

Vi på CodeLedge tillhandahåller Sveriges bästa WordPress-utvecklingstjänster. Vi är experter på att göra en webbplats helt säker från hackare och lätt att ladda. Prata gärna med oss ​​på hi@codeledge.com eller få en offert härifrån.

Lämna ett svar

Din e-postadress kommer inte publiceras. Obligatoriska fält är märkta *

Translate »