Hur du enkelt fixar det uppdaterade WordPress 5.5 jQuery-problemet

augusti 25, 2020
8-intressanta-fakta-som-du-inte-vet-om-Facebook
8 Intressanta Fakta Som du inte vet om Facebook
augusti 24, 2020
Topp 5 sätt att återställa ditt sociala medier rykte i Sverige
Topp 5 sätt att återställa ditt sociala medier rykte i Sverige
augusti 26, 2020
Hur du enkelt fixar det uppdaterade WordPress 5.5 jQuery-problemet

Hur du enkelt fixar det uppdaterade WordPress 5.5 jQuery-problemet

WordPress 5.5 är till stor del en framgång. Men det har skett olika sammanstötningar från teman och plugins som orsakade webbplatser att bryta. Troligtvis kommer den största frågan från WordPress beslut att utvisa den föråldrade jQuery Migrate.

Det första steget i moderniseringen av WordPress var att ta bort jQuery Migrate 1.x i WordPress 5.5. Det är också det som gör att vissa webbplatser går sönder.

Vissa WordPress-teman och plugins använder äldre jQuery-skript, vilket orsakar en rad problem.

Enligt WordPress-sidan för jQuery Migrate Helper:

”Med uppdateringen till WordPress 5.5 kommer ett migreringsverktyg som kallas jquery-migrate inte längre att aktiveras som standard.

Det kan leda till oväntat beteende i vissa teman eller plugins som kör äldre kod. ”

wordpress-jquery-migrate

Mer än 2 000 plugins med jQuery-konflikter

Som antyds av ett inlägg på WordPress, en sökning i plugin-katalogen som genomfördes för två veckor sedan hittade mer än 2 000 plugins som hade kolliderat.

Som anges av en WordPress Core Committer som gjorde forskningen:

“För teman ger dessa ändringar i sökningen resultaten från ~ 2600 teman till ~ 250 teman, med endast 5 som har mer än 10 000 aktiva installationer.”

wordpress-5-5-plugin-conflict

Listan skapades för två veckor sedan. Mängden plugins som har problem bör nu vara mindre.

Mer än 200 teman med konflikter

Listan upptäckte också över 200 teman som bröt.

“För teman ger dessa ändringar i sökningen resultaten från ~ 2600 teman till ~ 250 teman, med endast 5 som har mer än 10 000 aktiva installationer.”

Några personer kanske stöter på problem med sina teman på grund av föråldrad kod. Men några av dessa problem är på grund av plugins som är paketerade med dessa teman. Exempelvis paketeras premiumsidebyggar-plugins och reglage-plugins rutinmässigt med vissa teman. Men eftersom de är premium kommer de inte riktigt att uppdateras till den senaste versionen, beroende på din programvarulicens.

Om en uppgradering till den senaste versionen av ett tema inte löser problemet kan du installera WordPress Enable jQuery Migrate Helper för att återställa funktionaliteten.

Men varnas för att detta bara är en tillfällig lösning. Det kan vara användbart att felsöka din webbplats för att skilja vilken funktionalitet som orsakar problemet. När funktionen har identifierats kan du ha möjlighet att ladda ner ett aktuellt plugin för att hantera den trasiga funktionen.

Fortsätt läsa för att veta mer om felsökning.

Hur du felsöker WordPress 5.5-uppdatering

En av metoderna för att felsöka ett problem är att använda Chrome Dev Console. Att komma åt konsolen är lika enkelt som att klicka på F12-knappen i Windows.

Det alternativa sättet är att trycka på den vertikala tre prick-menyn i det övre högra hörnet och välja fler verktyg och sedan utvecklarverktyg.

Här är en skärmdump av vad ett fel skulle likna:

chrome-dev-console-errors

När du klickar på filen får du en annan skärm som har felet. Du kan sedan kunna knacka på den röda X-symbolen och en pop-up visar vad felet är.

example-of-js-error

Vanliga problem efter uppgradering till WordPress 5.5

Vissa av problemen är fruktansvärda att vissa av förläggarna inte kan logga in igen.

Många av de problem som vissa utgivare stöter på efter uppdatering till WordPress 5.5 identifieras med att förlora webbplatsfunktionaliteten.

WordPress 5.5 Uppdatera problem

  • Classic Editor fungerar inte
  • Knapparna “Lägg till media” och “Ställ in bild” fungerar inte
  • Textvy fungerar inte i 5.5
  • Block Editor visar tomt
  • Saknar databasuppdatering
  • Bildreglaget fungerar inte
  • Mobilmeny försvinner
  • Sökfältet slutar fungera
  • Det här är bara en del av de problem som användare stöter på

Den mest effektiva metoden för att fixa WordPress 5.5 jQuery-problem

WordPress har släppt ett plugin som återställer jQuery Migrate-biblioteket. Installering av detta plugin kommer att göra att din webbplats fungerar igen. Men…

Plugin fixar inte faktiskt vad som är fel med din webbplats.

Vad plugin gör är att din webbplats fungerar igen. Men det fixar inte vad som är fel med webbplatsen.

Det som är fel med webbplatsen är en föråldrad plugin eller tema. Om din bildreglage inte fungerar är problemet antagligen plugin för bildreglage. Att uppdatera plugin är en lösning.

Men om det inte finns någon uppdatering för plugin som måste uppdateras använder du förmodligen ett övergivet plugin. En övergiven plugin är vanligtvis en som inte har uppdaterats på länge.

Vad som utgör en “lång tid” är inte klart eftersom vissa plugins inte behöver uppdateras så ofta.

De flesta plugin-designare förbättrar sin produkt. Så i allmänhet, om ett plugin inte har uppdaterats på ett år eller mer, är det troligtvis något övergivet.

Det är idealiskt att sluta använda det insticksprogrammet. Övergivna plugins kan bli säkerhetsproblem.

När det gäller ett övergivet plugin är det en smart tanke att hitta ett mer aktivt underhållet plugin som gör samma sak.

Plugin som du måste återställa funktionalitet till din WordPress-webbplats kallas Aktivera jQuery Migrate Helper. Du kan ladda ner den här.

Aktivera jQuery Migrate Helper-plugin är inte rätt för vad som bröt under uppdateringen av WordPress 5.5. Det är bara en metod för att återställa funktionalitet.

Det är viktigt att ta nästa steg med att diagnostisera vad som är trasigt och fixa det verkliga problemet.

När plugin eller tema är fixat kommer du att vara på en överlägsen plats när det gäller säkerhet och användarupplevelse för dina besökare.

Vi på CodeLedge erbjuder Sveriges bästa WordPress-utvecklingstjänster. Om du har problem med din nya WordPress 5.5-uppdatering, kontakta oss gärna på hi@codeledge.com eller få en offert härifrån.

Lämna ett svar

E-postadressen publiceras inte. Obligatoriska fält är märkta *

Translate »